The issue causing the service disruption has been resolved, and Health Gorilla services have been fully restored. Our team has confirmed that the platform is operating normally.
We appreciate your patience while we worked to address this issue. If you continue to experience any problems, please contact our support team.
Posted Mar 13, 2026 - 14:12 CDT
Update
We are continuing to investigate this issue.
Posted Mar 13, 2026 - 14:11 CDT
Update
Health Gorilla is currently experiencing a service disruption and the platform is temporarily unavailable. Our engineering team is actively investigating the issue and working to restore service as quickly as possible.
We will continue to provide updates here as more information becomes available. Thank you for your patience.
Posted Mar 13, 2026 - 13:07 CDT
Update
Health Gorilla is currently experiencing intermittent slowness within our web portal. Our team is actively investigating the issue and working toward a resolution, and we are continuing to monitor and analyze the situation to ensure it is fully addressed.
We appreciate your patience and will provide updates as they become available.
Posted Mar 13, 2026 - 09:11 CDT
Investigating
Health Gorilla is currently experiencing intermittent slowness within our web portal. Our team is actively investigating the issue and working toward a resolution.
We will continue to provide updates as they become available. Thank you for your patience.