Health Gorilla Impacted by AWS Service Issues 2025-10-20

Resolved

AWS has resolved the issues that caused the performance issues in both UI and API.
Posted Oct 21, 2025 - 15:53 CDT

Monitoring

Our services are recovered, as have messaging services. Our service provider has resolved the issue and upstream services are recovering as well. You should see less service disruptions as the individual data centers and availability zones recover fully.
Posted Oct 20, 2025 - 16:50 CDT

Identified

The Health Gorilla systems, including both UI and APIs, are currently being impacted by the AWS Service issues. You may see slow or unresponsive UI behavior, and API calls may have slow responses, or may receive 5xx level disconnects. We will update this page when we receive additional information from AWS.
Posted Oct 20, 2025 - 11:22 CDT
This incident affected: Web Portal, API Server and Lab Network (Lab Connectivity (General)).