Performance Degradation Issue 2025-10-15

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 11:17 CDT

Identified

In order to resolve the performance degradation issues with our UI and API, Health Gorilla is undergoing database maintenance. Initial UI login will take longer than normal, but moving through the UI screens should speed up. This maintenance will be completed this weekend.
Posted Oct 17, 2025 - 13:06 CDT

Investigating

We are currently investigating a performance degradation issue that was first identified at 13:37pmCT on 10/15/2025. This may impact both UI users and API queries and responses.
Posted Oct 15, 2025 - 13:52 CDT
This incident affected: Web Portal and API Server.